Home/Computers & IT/Allow Adobe Creative Cloud Through a Proxy Server

Adobe Creative Cloud is fantastic & I use it all the time.

But when you are in an environment where you have a proxy server you can encounter issues. So how do you allow adobe creative cloud through a proxy server?
There are plenty of posts out there where everyone is asking how to add exceptions for it but no one ever replies or gives you the correct information.

All you need is a list of Adobe Creative Cloud Proxy Exceptions

Its very simple!
Add the below domains & ports to your Proxy Servers white list/ Exception List

adobe.com port: 80
ccmdls.adobe.com port: 443
ims-na1.adobelogin.com port: 443
adobeid-na1.services.adobe.com port: 443
imsprod06.adobelogin.com port: 443
use.typekit.net port: 443
p.typekit.net port: 443
sstats.adobe.com port: 443
oobe.adobe.com port: 443
prod-rel-ffc-ccm.oobesaas.adobe.com port: 443
prod-rel-ffc.oobesaas.adobe.com port: 443
lm.licenses.adobe.com port: 443
ccmdl.adobe.com port: 80
swupmf.adobe.com port: 443
swupdl.adobe.com port: 80
interaction.adobe.com port: 443

now you may have to delete the old opm.db file if you still encounter issues which is located

Windows: [System drive]:Users[user name]AppDataLocalAdobeOOBE
Mac OS: /Users/[user name]/Library/Application Support/Adobe/OOBE folder

I tested this & confirmed it works for all the graphic designers in my workplace.

 

Any issues hit me up ill help you out.

By | 2016-03-11T19:32:14+00:00 October 18th, 2013|Computers & IT|16 Comments

16 Comments

  1. Kevin November 5, 2013 at 1:41 am - Reply

    Hi,
    many thanks this is working well.
    We were searching for days to get Creative Cloud working.
    I would like to know why the Adobe technicians arent aware of this.

    • Sammit
      Sammit November 5, 2013 at 11:52 pm - Reply

      Hi Kevin,

      Honestly I have no idea why they have not done a article about this.
      I guess its lack of support from their end.
      This is why I wrote this post 🙂

      Glad I could help you out!

  2. jc January 28, 2014 at 10:33 pm - Reply

    thanks … i have been looking for an answer for months

  3. Mahmoud April 4, 2014 at 2:38 am - Reply

    Thanks Sammit,

    on our case, we are using Microsoft threat management gateway as a proxy, and the problem is only solved after excluding the *.adobe.com and *.adobelogin.com and *.adobeexchange.com from malware inspection

  4. Curtis September 3, 2014 at 4:59 am - Reply

    Is this still accurate for OSX 10.9.4? It didn’t work for me and I’m having trouble finding the opm.db file.

    • Sammit
      Sammit September 3, 2014 at 11:06 am - Reply

      no issues with latest update of OSX on my end. use the search bar to see if opm.db even exists on your mac. if nothing comes up then you don’t need delete the file because it hasn’t even been created yet.

  5. Lerato April 28, 2015 at 10:03 pm - Reply

    Hi…I am using MacBook Pro 13inch(10.9.3) laptop. I’ve followed the exact instructions given by Sammit. But Still my creative cloud is not working. Instead it says “Unable to reach Adobe servers. Please check your firewall settings and try again in a few minutes”. Please help 🙁

  6. Dominic July 27, 2015 at 7:33 pm - Reply

    Why is activate.com in the list? This domain has nothing to do with Adobe according to the “whois” database.

  7. Miguel August 15, 2015 at 7:12 am - Reply

    We are using websense and still cannot get this to work after whitelisting the suggested URLs. Any thoughts? Thanks!

    • Sammit
      Sammit March 11, 2016 at 7:32 pm - Reply

      Hi Miguel, I have updated the list of domains & ports to add. Creative cloud has had an update & uses a few more now.

  8. Poldy September 16, 2015 at 7:14 pm - Reply

    yo sammit,

    I was facing the same problem and applied your fix to no avail! until I stumbled upon this:
    https://helpx.adobe.com/creative-cloud/packager/creative-cloud-packager.html#port_info
    after I whitelisted all pages in my proxy ACC was working properly. so if anyone runs into this again try adding all of the sites to your whitelist. did the trick for me.
    apart from that, thx for posting this!!!

    stay that 😉
    p.

  9. Tony Dovale March 10, 2016 at 6:40 pm - Reply

    Hi help please been legally paying for 4 months and still canot get it working.,..

    02/12/16 10:14:47:820 | [INFO] | | ACC | LBS | ApplicationFacade | | | 6480 | ****************Starting LBS workflow*******************
    02/12/16 10:14:47:836 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | LBS launched in SELF-UPDATE mode
    02/12/16 10:14:47:836 | [INFO] | | ACC | LBS | IPCWrapper | | | 6480 | Initializing Communication Channel with ACC with pipename: {098A984A-4F32-46EF-B6D0-D39BA1E6F766}
    02/12/16 10:14:48:286 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | ACCC System requirements check passed
    02/12/16 10:14:48:759 | [INFO] | | ACC | LBS | ProductInfo | | | 6480 | Product Sap Code not specified in the product information file
    02/12/16 10:14:48:759 | [INFO] | | ACC | LBS | ProductInfo | | | 6480 | Applet Version not specified in the product information file
    02/12/16 10:14:48:759 | [INFO] | | ACC | LBS | ProductInfo | | | 6480 | Applet ID not specified in the product information file
    02/12/16 10:14:48:759 | [INFO] | | ACC | LBS | ProductInfo | | | 6480 | Product locale not specified in the product information file
    02/12/16 10:14:48:759 | [INFO] | | ACC | LBS | ProductInfo | | | 6480 | Product name not specified in the product information file
    02/12/16 10:14:48:764 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | Bootstrap LBS is successful
    02/12/16 10:14:48:775 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | Bootstrapper Lock acquired
    02/12/16 10:14:48:786 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | LBS Lock acquired
    02/12/16 10:14:59:793 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | PDM completed with error in downloading PIM with error 0
    02/12/16 10:14:59:896 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | Successfully downloaded pim at path C:\Windows\TEMP\{90090F10-3B12-4930-A15B-6A13E711CC80}\CCLBS\PDIM\AdobePIM.dll
    02/12/16 10:15:00:890 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | pim validation successful
    02/12/16 10:15:00:912 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | PIM loading is successful
    02/12/16 10:15:00:924 | [INFO] | | ACC | LBS | InstallThreadProc | | | 7864 | Installing latest Adobe Creative Cloud
    02/12/16 10:15:00:967 | [INFO] | | ACC | LBS | ETS | | | 7864 | osVersion Received is 6.3.0
    02/12/16 10:15:00:967 | [INFO] | | ACC | LBS | ETS | | | 7864 | Event Guid generated is: ‘267ed7a1-1c07-4197-82ba-45bf245966ce’
    02/12/16 10:15:00:967 | [INFO] | | ACC | LBS | ETS | | | 7864 | IsAutoUpdate sending in ETC event is 1
    02/12/16 10:15:00:967 | [INFO] | | ACC | LBS | ETS | | | 7864 | workflowIdAsParameter Received is {FCBB4D15-04A1-4BAB-88C1-F284196D6F8C}
    02/12/16 10:15:00:967 | [INFO] | | ACC | LBS | ETS | | | 7864 | osVersion Received is 6.3.0
    02/12/16 10:15:00:967 | [INFO] | | ACC | LBS | ETS | | | 7968 | Event with guid ‘267ed7a1-1c07-4197-82ba-45bf245966ce’ is being sent
    02/12/16 10:15:00:969 | [INFO] | | ACC | LBS | ETS | | HTTPConnector | 7968 | GetIEProxyInfo – Failed to get proxy for the url, error:12180
    02/12/16 10:15:03:590 | [INFO] | | ACC | LBS | ETS | | HTTPConnector | 5068 | HTTP Request Status code 200.
    02/12/16 10:15:03:590 | [INFO] | | ACC | LBS | ETS | | HTTPConnector | 7968 | The http request returned HTTP_Status:0 HttpCommunicator error:0
    02/12/16 10:30:41:329 | [INFO] | | ACC | LBS | ETS | | | 7864 | osVersion Received is 6.3.0
    02/12/16 10:30:41:329 | [INFO] | | ACC | LBS | ETS | | | 7864 | Event Guid generated is: ’08c461e3-4980-44e6-940c-a1a8af655e32′
    02/12/16 10:30:41:329 | [INFO] | | ACC | LBS | ETS | | | 7864 | IsAutoUpdate sending in ETC event is 1
    02/12/16 10:30:41:329 | [INFO] | | ACC | LBS | ETS | | | 7864 | workflowIdAsParameter Received is {FCBB4D15-04A1-4BAB-88C1-F284196D6F8C}
    02/12/16 10:30:41:329 | [INFO] | | ACC | LBS | ETS | | | 7864 | osVersion Received is 6.3.0
    02/12/16 10:30:41:329 | [INFO] | | ACC | LBS | ETS | | | 7968 | Event with guid ’08c461e3-4980-44e6-940c-a1a8af655e32′ is being sent
    02/12/16 10:30:41:329 | [INFO] | | ACC | LBS | ETS | | HTTPConnector | 7968 | GetIEProxyInfo – Failed to get proxy for the url, error:12180
    02/12/16 10:30:41:751 | [INFO] | | ACC | LBS | ETS | | | 7864 | osVersion Received is 6.3.0
    02/12/16 10:30:41:751 | [INFO] | | ACC | LBS | ETS | | | 7864 | Event Guid generated is: ‘5bae14f6-784a-453b-9c7b-3a6ac8b6f5b3’
    02/12/16 10:30:41:751 | [INFO] | | ACC | LBS | ETS | | | 7864 | IsAutoUpdate sending in ETC event is 1
    02/12/16 10:30:41:751 | [INFO] | | ACC | LBS | ETS | | | 7864 | workflowIdAsParameter Received is {FCBB4D15-04A1-4BAB-88C1-F284196D6F8C}
    02/12/16 10:30:41:751 | [INFO] | | ACC | LBS | ETS | | | 7864 | osVersion Received is 6.3.0
    02/12/16 10:30:43:157 | [INFO] | | ACC | LBS | ETS | | HTTPConnector | 5708 | HTTP Request Status code 200.
    02/12/16 10:30:43:157 | [INFO] | | ACC | LBS | ETS | | HTTPConnector | 7968 | The http request returned HTTP_Status:0 HttpCommunicator error:0
    02/12/16 10:30:43:157 | [INFO] | | ACC | LBS | ETS | | | 7968 | Event with guid ‘5bae14f6-784a-453b-9c7b-3a6ac8b6f5b3’ is being sent
    02/12/16 10:30:43:157 | [INFO] | | ACC | LBS | ETS | | HTTPConnector | 7968 | GetIEProxyInfo – Failed to get proxy for the url, error:12180
    02/12/16 10:30:44:350 | [INFO] | | ACC | LBS | ETS | | HTTPConnector | 2144 | HTTP Request Status code 200.
    02/12/16 10:30:44:350 | [INFO] | | ACC | LBS | ETS | | HTTPConnector | 7968 | The http request returned HTTP_Status:0 HttpCommunicator error:0
    02/12/16 10:31:15:934 | [INFO] | | ACC | LBS | IPCWrapper | | | 7864 | Sent IPC packet to quit ACC with data: QUIT

    02/12/16 10:31:28:318 | [INFO] | | ACC | LBS | ETS | | | 7864 | osVersion Received is 6.3.0
    02/12/16 10:31:28:318 | [INFO] | | ACC | LBS | ETS | | | 7864 | Event Guid generated is: ‘b4bcf8b6-a162-4b8e-9a32-7e0c5e16ff9e’
    02/12/16 10:31:28:318 | [INFO] | | ACC | LBS | ETS | | | 7864 | IsAutoUpdate sending in ETC event is 1
    02/12/16 10:31:28:318 | [INFO] | | ACC | LBS | ETS | | | 7864 | workflowIdAsParameter Received is {FCBB4D15-04A1-4BAB-88C1-F284196D6F8C}
    02/12/16 10:31:28:318 | [INFO] | | ACC | LBS | ETS | | | 7864 | osVersion Received is 6.3.0
    02/12/16 10:31:28:318 | [INFO] | | ACC | LBS | ETS | | | 7968 | Event with guid ‘b4bcf8b6-a162-4b8e-9a32-7e0c5e16ff9e’ is being sent
    02/12/16 10:31:28:318 | [INFO] | | ACC | LBS | InstallThreadProc | | | 7864 | ACC installation is completed successfully
    02/12/16 10:31:28:318 | [INFO] | | ACC | LBS | ETS | | HTTPConnector | 7968 | GetIEProxyInfo – Failed to get proxy for the url, error:12180
    02/12/16 10:31:28:349 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | Launching Adobe Creative Cloud
    02/12/16 10:31:28:349 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | Checking whether LBS lauched in Customized Mode
    02/12/16 10:31:28:349 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | LBS Launched in Double Click Mode
    02/12/16 10:31:28:349 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | Auto Update Mode. Going to signal the LBS as ACC Laucnher to laucnh ACC
    02/12/16 10:31:28:349 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | Auto Update Mode. Create Event Successful. Going to signal the LBS as ACC Laucnher to laucnh ACC
    02/12/16 10:31:28:349 | [INFO] | | ACC | LBS | WorkflowManager | | | 6480 | Auto Update Mode. Faield in setting the event to 183
    02/12/16 10:31:28:365 | [INFO] | | ACC | LBS | ETS | | | 6480 | Waiting for the async thread to get the task completed
    02/12/16 10:31:29:557 | [INFO] | | ACC | LBS | ETS | | HTTPConnector | 492 | HTTP Request Status code 200.
    02/12/16 10:31:29:557 | [INFO] | | ACC | LBS | ETS | | HTTPConnector | 7968 | The http request returned HTTP_Status:0 HttpCommunicator error:0
    02/12/16 10:31:29:557 | [INFO] | | ACC | LBS | ETS | | | 7968 | Async thread is completed. Now exiting from function.
    02/12/16 10:31:29:557 | [INFO] | | ACC | LBS | ApplicationFacade | | | 6480 | ACC installation end with exit code: 0
    02/12/16 10:31:29:557 | [INFO] | | ACC | LBS | ApplicationFacade | | | 6480 | ****************Closing LBS workflow*******************

    • Sammit
      Sammit March 11, 2016 at 7:30 pm - Reply

      Hi Tony, I have just updated the list of domains & ports to add to your whitelist in your proxy server. try adding all of these & let me know how you go.

  10. S. Hewson June 28, 2016 at 6:10 pm - Reply

    Hi Sammit

    Do you know if Adobe is using new download locations with last week’s major update to CC 15? I am behind an SBS server and ISA proxy server and can no longer download updates. The agent I was in an online chat with yesterday said they have changed their method of download, and when I tried last week I was finding 403 errors in the download log, so it looks to me as though ISA Server is blocking access. I have all the previous relevant adobe sites whitelisted in ISA Server and in IE’s trusted sites and it has been working fine up to now, so I am now at a loss. I’ve removed CC Desktop numerous times now (using Adobe’s dedicated tool) and reinstalled it but with no luck. I am waiting for second line support to respond to me with (hopefully) some new download site info.

    regards

    Susie

  11. Hector July 13, 2016 at 12:24 pm - Reply

    Hey! Where exactly is the white list / exception list?

  12. Fatty February 28, 2017 at 3:02 pm - Reply

    Where do I fine the white list?

Leave A Comment